Project Viewer

We have seen how to create a project and add data layers to it. Before performing an analysis based on these data layers, we need to understand how to organize and explore the data in the Project Viewer.

Project Viewer Sections

The interface of Pathfinder consists of four major components:

  • The left panel (1) lists the layers added to the project, grouped by category.

  • The top menu (2) includes commands to modify the project and its scenarios, calculate and export the analysis results, and access the application configuration.

  • The right panel (3) has specific sections to manage scenarios and their results.

  • The central view (4) offers an interactive 2D map or 3D view of the data and the results.

_images/viewerStructure.jpg

Side panels (sections 1 and 3) can be hidden and reopened by clicking on their pull handles:

_images/sidePanelHandler.jpg

Organize Data

Data layers are listed in the left panel, grouped by their category. The category is assigned when a layer is added to the project, but it can be changed later.

_images/layersPanel.jpg

The role of categories is to group layers which share a common theme (for instance, existing infrastructures, physical environment, land property, etc.) so the user can adjust their weight (importance) in the analysis scenario.

Note

Users who are not admin/staff can’t create, modify or delete categories or their layer list. Ask your administrator to do it for you.

Create New Category

A new category can be created from the Project/New Category menu option and also from the corresponding button in the Layers panel header.

_images/newCategory.jpg

The category name is assigned in the following dialog:

_images/newCategoryDlb.jpg

Change Layer Category

Layers can be moved to a different category by clicking on them and dragging them to a different group.

_images/layerDrag.jpg

The category of a layer can also be changed in the Layer Preprocessing dialog, which opens from the Project menu or from the button in the Layers panel header.

_images/layerPreprocBtn.jpg

Change Names

To change the name of a category or layer, double-click on its name, type the modified name and hit Enter, or click outside the Layers panel to cancel the change.

_images/layerChangeName.jpg

Delete a Layer

A layer can be removed by using the Delete button in its side panel. First, open the side panel to the right of the layer item, and then click on the Delete button:

_images/layerDelete.jpg

A dialog will prompt the user to confirm the operation:

_images/layerDeleteConfirm.jpg

Note

If a layer is removed from the project, it can be recreated from the base data without the need to upload it again.

Delete a Category

Like the layers, a category can be removed from the project by using the Delete button in its side panel.

_images/categoryDelete.jpg

A dialog will prompt the user to confirm the operation:

_images/categoryDeleteConfirm.jpg

Note

If a category is removed, all the layers it contains will also be removed from the project.

Explore Data

The main view of Pathfinder is used to explore data added to the project and the results of the analysis processes.

In order to display a layer in the view, it must be made visible.

Layer Visibility

A layer can be displayed in two ways:

  • Original layer: Displays the original vector features of the layer without buffering. Use the first visibility button:

    _images/layerVisOriginal.jpg

    This is the only visibility option available for raster layers:

    _images/layerVisRaster.jpg

  • Buffered layer: Available for vector data. It displays the features with buffering, showing one or multiple rings depending on the layer configuration. For multiple rings, different transparency values are applied. Use the second visibility button to switch this mode on:

    _images/layerVisBuffer.jpg

The following image shows the difference between the original (left) and the buffered displays (right):

_images/originalVersusBuffered.jpg

The visibility of all buffered layers in a category can be changed at once with the button located in the category header, identical to the layers’.

_images/showAllLayers.jpg

Note

Since raster layers do not have a buffered version, the toggle to display all buffered layers does not affect them.

Layer Color

To better understand the information provided by different layers in the view, a different color can be assigned to each layer.

Click on the colored square next to the layer name to open the color picker.

_images/layerColor.jpg _images/colorPicker.jpg

You can also control the transparency of the color by using the transparency slider in the color picker typing an opacity value in the A field (0 means fully transparent, 100 completely opaque). Transparency is only applied to the Map view.

When applied to a raster layer, the color is displayed lighter for smaller values in the raster and darker for larger values, as in this slope example:

_images/rasterColor.jpg

Search Layers

If your project has many layers, it may be difficult to find quickly the one you want to edit. To quickly find layers by name, use the Layer Search field at the bottom of the Layers panel. Type one or more characters, and only the layers whose name includes the typed text will be shown in the panel:

_images/layerSearch.jpg

Map View

Data and results are displayed in the central view. By default, this shows an interactive 2D Map, but most its options and tools are common to the 3D View. These tools can be found in the View menu and also as floating buttons on either view.

_images/mapView.jpg

The View Menu provides direct access to view options. For the 2D Map, these are:

_images/viewMenu.jpg
  • Center View: zooms the view to the data extent.

  • Switch to 3D View (or back to 2D): it will use a 3D globe to display the data and results, including a realistic display of the pylons and cables, which can also be interactively moved by the user.

  • Presentation View: switches to a view mode with limited interaction capabilities, for public presentations.

  • Base Map: lets the user choose which map service to use as a background reference image.

  • Show options, including:

    • Legend: toggles on/off the color ramp legend to interpret Resistance Maps and Corridors.

      _images/legend.jpg

    • Full Screen: toggles on/off the full screen mode (F11 key can also be used).

    • Pylon: shows or hides the visualization of pylons

Tools

This menu contains tools to operate on both the Map view and the 3D view:

_images/toolsMenu.jpg
  • Identify Point: lets the user find out what the resistance values at a certain location on the view. It is described in the analysis page.

  • Search Location: find a place by typing its name. A list of matching places will be offered from which the user can pick one to zoom to:

    _images/searchLocation.jpg

  • Measurement Tools: opens the measurement toolset on the view. This toolset includes distance, area and elevation measurement tools. Note that the elevation values returned by this tool are Ellipsoidal Height values, not Orthometric Height (above sea level).

    _images/measurement.jpg

  • Pylon tools: it opens the pylon toolset on the view. This toolset includes tools to move and get info about individual pylons. The 3D version has an additional tool to detect conflicts between cables and terrain.

    To move a path point, activate the Move tool, and click and drag on one of the yellow circles appearing around the points.

    _images/pylonTools2D.jpg

    Right click to finish the editing operation and accept the changes if you want to keep them.

  • Screenshot: captures an image of the view and saves it to local disk.

  • Streetview: very convenient to check the situation on the ground. See below.

3D View

By clicking on the View/3D View menu option or on the 3D tool button on the 2D Map, the view can switch to a 3D perspective of the project area.

_images/view3D.jpg

In this view we have some additional View menu options:

  • Add 3D Assets: allows users to add custom 3D assets to the view.

  • Additional View/Show options are:

    • Buildings: toggles on/off the display of world buildings.

      _images/buildings.jpg

  • Terrain: toggles on/off the elevation data. Note that switching off the terrain may lead to some objects “floating” above the zero elevation plane.

  • Underground: turns on/off the underground mode with a semi-transparent surface and underground navigation.

    _images/underground_3D.jpg

To check how the Pylon Tools work in 3D, see the analysis page.

Navigation

Same as in the 2D Map view, use the left mouse/trackpad button to pan, and zoom in and out with the mouse wheel or with two fingers on the trackpad.

In addition, you can rotate the view with the middle mouse button (or pressing the wheel), or by pressing the Ctrl key while using the left mouse.

There is also a compass in the bottom right corner of the 3D View, which you can use to know the orientation of the 3D view and navigate around.

_images/compass.jpg

Identify and edit feature attributes

Checking the attributes of geographic elements might be important to classify the input data into layers to assign different resistance values.

To identify the attributes of objects in a specific layer, use the Identify icon in that layer’s settings panel:

_images/identifyAttrib.jpg

The cursor will change into a blue dot. Click on an object of the selected layer:

_images/identifyCursor.jpg

After clicking, if one or more features are found in the selected location, their IDs and attributes will be shown in the Identify dialog:

_images/identifyAttrDlg.jpg

The features values can then be edited for uploaded and WFS layers, but not for OpenStreetMap layers. Type the value you want and then click Enter. When you do so and the change is performed, a green checkbox will appear next to it.

_images/identifyEdit.jpg

Note

Attribute editing has important consequences:

  • The affected layers must be processed again so the attribute change takes effect in the elements included in the layer. Also, the resistance map and other results must also be recalculated.

  • Attribute value changes affect the base dataset from which layers in different project may take their data, so all the projects using the modified data will change if their layers are reprocessed. This may be specially dangerous when editing WFS layers. A lot of projects and users may depend on the service data, so be careful with these changes and notify affected users.

StreetView tool

Sometimes it is convenient to check the situation on the ground to verify the constraints provided by the data sources. Some elements like existing lines, buildings, etc. might be different than we expected, or we might need to check their type or precise location.

The Street View by Google comes in handy to do these quick checks. Just click on a street or road where StreetView is available (unfortunately, the available areas are not displayed).

_images/streetViewMenu.jpg

_images/streetView.jpg

This tools works in both the 2D and 3D views.

Presentation view

This option in the View menu can be used to simplify the project viewer interface for public presentation purposes.

_images/presentation.jpg

Its effect is to hide some user interface elements like the right panel, menus and layer resistance information.

Touch-based interaction in Pathfinder has also been improved to ease the use of this kind of displays.

_images/presentationView.jpg

To exit this mode, press the key combination <Ctrl> + <Alt> + <Shift> + P.




Disclaimer: the scenarios depicted in this manual do not represent actual customer projects or infrastructure proposals, and are presented for demonstration purposes only.

For more help, please use the help chat in the application, or contact Gilytics.